[OpenJDK 2D-Dev] Review request for bug 100053
Jim Graham
Jim.A.Graham at Sun.COM
Fri Oct 2 21:26:01 UTC 2009
That looks fine.
A note on code style, though. The following form would better match the
indentation/continuation style used in the rest of this file and the 2D
code:
781 if (crossingIndices != null &&
782 crossingIndices.length > DEFAULT_INDICES_SIZE)
783 {
...jim
Roman Kennke wrote:
> Hi Jim,
>
> I think you are right. I think the idea is to keep the array around to
> avoid massive load on the GC. And if the array needs to be grown (i.e.
> very rarely), it gets shrinked back to default size. So I would go with:
>
>> Shouldn't it be "if (array != null && array.length > DEFAULT)"?
>
> The updated webrev is here:
>
> http://cr.openjdk.java.net/~rkennke/100053/webrev.02/
>
> I tested this with the testcase and Java2Demo and had no problems with
> this.
>
> Ok now?
>
> Thanks, Roman
>
>
More information about the 2d-dev
mailing list