[OpenJDK 2D-Dev] [9] Review Request: 8061832 J2DBench can be improved

Phil Race philip.race at oracle.com
Thu Nov 6 18:48:00 UTC 2014


   82             if (ImageTests.hasVolatileImage) {
   83                 if(ImageTests.hasTransparentVolatileImage) {
   84                     volimgdestroot = new Group.EnableSet(destroot, "volimg",
   85                                                          "Output to Volatile Image");
   86
   87                     volimgdestroot.setHorizontal();
   88                     new VolatileImg();
   89                     new VolatileImg(Transparency.OPAQUE);
   90                     new VolatileImg(Transparency.BITMASK);
   91                     new VolatileImg(Transparency.TRANSLUCENT);
   92                 } else if (ImageTests.hasVolatileImage){
   93                     volimgdestroot = new Group.EnableSet(destroot, "volimg",
   94                                                          "Output to Volatile Image");
   95
   96                     volimgdestroot.setHorizontal();
   97                     new VolatileImg();
   98                 }
   99             }

The test at line 93 is redundant .. it just needs to be an else { ..}
since we are only in this block if it passed at line 82.
Also line 83 has "if(" - should be "if ("

Am I right in understanding that the huge 4000x4000 option is disabled by default ?
I think disabling by default is the right thing for that.

-phil

On 11/5/2014 11:17 AM, Sergey Bylokhov wrote:
> Hello.
> Please review the fix for jdk 9.
>
> Change description:
> - Test groups were wrapped by JScrollPane
> - Translucent volatile images now can be used as source and destination
> - Additional source/destination were added(TYPE_4BYTE_**)
> - Main window will be created on EDT at the center of the screen
> - Support of the huge shapes were added(4000x4000)
> - Support of the interpolation was added, by default nearest neighbor 
> is used
> - Two cmm tests depended on the default enum.toString() 
> implementation, and was broken when usage of enums were removed. I 
> reused abbreviation as a name of the test
> - "Image Rendering Tests" tab was renamed to "image rendering 
> benchmark", because now it has an options as well
> - "Touch src image before every operation" was moved from the "image 
> rendering source" tab to the "image rendering benchmarks" and placed 
> in the same group as interpolation
> - The new image rendering test was added: drawimage(img, x, y, w*0.5, 
> h*0.5, obs); will simplify testing of some blits on the retina display
>
>
> Bug: https://bugs.openjdk.java.net/browse/JDK-8061832
> Webrev can be found at: 
> http://cr.openjdk.java.net/~serb/8061832/webrev.02
>




More information about the 2d-dev mailing list