[aarch64-port-dev ] AARCH64: 8064611: Changes to HotSpot shared code
Vladimir Kozlov
vladimir.kozlov at oracle.com
Fri Nov 14 03:10:48 UTC 2014
Hi Andrew,
os_linux.cpp
I assume you will implement Goetz's suggestion (similar to EM_486).
memory/metaspace.cpp
Use {} for first check. Align ReservedSpace() calls parameters to '('.
can_use_cds_with_metaspace_addr() should be called only inside #if
INCLUDE_CDS.
opto/graphKit.cpp
May be it should be PPC64_ONLY(release) NOT_PPC64(unordered)?
opto/library_call.cpp
I don't see membar changes for volatile stores in inline_unsafe_access().
opto/parse2.cpp
To avoid platform specific code use
StoreNode::release_if_reference(T_OBJECT) there since that method
returns correct value with your change.
opto/parse3.cpp
I am fine with using AARCH macros here. Our code style requires using {}
for if's body - please add them at lines 288-290.
runtime/arguments.cpp
Is it really 128MB max value for ReservedCodeCacheSize on aarch64? What
is default ReservedCodeCacheSize size?
You may need to change next code if you can allocate only 128MB:
2547 } else if (ReservedCodeCacheSize > 2*G) {
2548 // Code cache size larger than MAXINT is not supported.
2549 jio_fprintf(defaultStream::error_stream(),
I think you need to add new platforms specific flag CodeCacheSizeLimit
and use it instead of our hard-coded 2Gb (maxint).
In new files Copyright's last year should be 2014.
Thanks,
Vladimir
On 11/12/14 8:49 AM, Andrew Haley wrote:
> On 11/12/2014 11:40 AM, Lindenmaier, Goetz wrote:
>> Hi Andrew,
>
> Hi,
>
> Thank you for your comment. I have prepared a new webrev at
>
> http://cr.openjdk.java.net/~aph/aarch64-8064611-1/
>
> which I hope addresses everything you mentioned.
>
> I haven't re-ordered any of the lists of processors because I think
> this is a separate issue.
>
> Andrew.
>
More information about the aarch64-port-dev
mailing list