<div dir="ltr"><div dir="ltr">On Wed, Feb 21, 2024 at 9:47 AM Stephen Colebourne <<a href="mailto:scolebourne@joda.org" target="_blank">scolebourne@joda.org</a>> wrote:<br></div><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">ie. I think "System" is a better on-ramp name as it actually leads to<br>
the "real thing"<br></blockquote><div><br></div><div>To pull this string a bit more, perhaps we could even tuck this away as a static class IO in System?</div><div><br></div><div>import static java.lang.System.IO.*; // Implicit</div><div><br></div><div>println("Hello");</div><div>System.IO.println("Goodbye"); // Explicit</div><div><br></div><div>That would free the java.io.* namespace of the burden of having a name for this thing which seems a bit out of place and awkward outside the context of implicit classes.</div><div><br></div><div>(Disclaimer: I'm casually throwing out a thought here without much thought, that's what bikeshedding is all about, right! :) </div><div><br></div><div>Eirik.</div><div><br></div></div></div>