<div dir="ltr"><div>I can no longer resist jumping in with an opinion... :)</div><div><br></div><div>From [compiler-dev]:</div><div><div dir="ltr">On Tue, Apr 23, 2024 at 10:36 AM Ethan McCue <<a href="mailto:ethan@mccue.dev" target="_blank">ethan@mccue.dev</a>> wrote:</div><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr">What's
going to suck to hear, but I think that you'll come around eventually,
is that extension methods do not improve code readability. They make it
harder to read o<font face="monospace">.method() </font><font face="arial, sans-serif">since it would be ambiguous whether </font><font face="monospace">.method</font><font face="arial, sans-serif"> is an instance method or an extension method.*</font><div><font face="arial, sans-serif"><br>They
*do* make it easier to write programs though. Without them you do have
to write more characters and you do sometimes have to break up method
chains.<br><br>Historically, given a choice between code readability and code writability/terseness, Java has erred towards the first.<br></font></div></div></blockquote><div><br></div><div>IMHO this is the heart of the problem. Personally I'm a fanatic about this - readability is 100x more important than writability if you're writing code which is going to be used & maintained for a long time (think enterprise, i.e., Java's sweet spot).</div><div><br></div><div>FWIW here's my previous rant on this topic <a href="https://mail.openjdk.org/pipermail/amber-dev/2022-November/007580.html" target="_blank">https://mail.openjdk.org/pipermail/amber-dev/2022-November/007580.html</a> (that was in a discussion about making all exceptions unchecked...)<br></div><div><br></div><div>-Archie<br></div></div></div><div><br></div><div><span class="gmail_signature_prefix">-- </span><br><div dir="ltr" class="gmail_signature">Archie L. Cobbs<br></div></div></div>