Member Patterns -- the bikeshed

forax at univ-mlv.fr forax at univ-mlv.fr
Wed Apr 3 14:23:22 UTC 2024


> From: "Brian Goetz" <brian.goetz at oracle.com>
> To: "Remi Forax" <forax at univ-mlv.fr>
> Cc: "amber-spec-experts" <amber-spec-experts at openjdk.java.net>
> Sent: Wednesday, April 3, 2024 2:48:40 PM
> Subject: Re: Member Patterns -- the bikeshed

> I would summarize your comments below as: Let's throw the entire model in the
> garbage, and replace it with something like Scala's "return an Optional<Tuple>"
> instead.

> We've been discussing the model for several years; you've been asking (and
> waiting patiently) for "when are we going to talk about declaration syntax",
> and now that we're there, you want to throw it all out and start over?
My makeup job was too big so you do not recognize your model behind :) 

There are two parts, the declaration part and the use-site part. 
Correct me if i'm wrong but apart the support of a method pattern with no prefix, we are in agreement here. 

For the declaration part, I think that 
carrier(int x, int y) asCartesian() 
is more readable than 
inverse () asCartesian(int x, int y) 

The inverse notation is a leaky abstraction in a leat two cases 
- when a modifier or an annotation is used. For an annotation, there is a notion of a target and the parameter target is at the wrong place, 
- when declaring a lambda, because in that case the parameters are not inversed. 

Now, what i call a carrier type is what you call a list of bindings. 
In terms of syntax, I think it is important to put a name in front of that list of bindings, i've proposed "carrier" so we provide a name for that feature, it's easier when discussing about it it or google it. 
That does not change the fact that a method that returns a carrier is a special method because it requires at least a special erasure (because overloading), and a special reflection API, 

But I hope, we will not cross the line and have to use new opcodes in the bytecode. 
For me, a method that returns a carrier is something that can be desugared classical Java elements like an enum or a record is desugared to a class. 

> We've discussed how strategies that rely on "ask the user to declare a record
> for every API point" feel clever for about five minutes, but start to feel old
> quickly.
yes, this is what you have to do actually if you simulate the feature with Java nowadays. Not, what you should have to do in the future. 
And the idea is to do better, among other things, we want to suport overloading. 

> The "carrier" concept in your examples seems to be just another way of
> reinventing multiple return -- with the added dis-bonus of being like but not
> quite the same as records. We've been pretty clear that "multiple return" is
> not the design center here.
The idea behind a carrier is to let users define their binding list is a way that does not feel too strange, that why I propose to add a name/keyword in front of the binding list. 

And I do not know how you define what a binding list is but multiple return + components description is a good definition for me. 

Rémi 

> The use of ! for indicating totality is interesting, that's worth thinking
> about.

> On 4/3/2024 6:21 AM, Remi Forax wrote:

>> I think that by not starting from the deconstructor, the notion of inverse
>> methods make less sense.
>> I think that the notion of carrier / carrier type is less disruptive that the
>> notion of member patterns.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.openjdk.org/pipermail/amber-spec-observers/attachments/20240403/47563ea1/attachment.htm>


More information about the amber-spec-observers mailing list