[code-reflection] RFR: Replace opField with opMethod for identified methods [v3]
Maurizio Cimadamore
mcimadamore at openjdk.org
Fri Dec 20 18:28:52 UTC 2024
On Thu, 19 Dec 2024 18:36:28 GMT, Mourad Abbay <mabbay at openjdk.org> wrote:
>> In this PR, instead of creating a field that will holds the textual representation of an identified method, we create a method (let's call it opMethod) that will returns the op of that method.
>
> Mourad Abbay has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains four additional commits since the last revision:
>
> - Change the name of the opMethod
> - Merge branch 'code-reflection' into opMethod
> - Apply suggestions
> - Replace opField with opMethod for identified methods
Marked as reviewed by mcimadamore (Reviewer).
src/jdk.incubator.code/share/classes/jdk/incubator/code/internal/CodeReflectionSymbols.java line 79:
> 77: syms.synthesizeEmptyInterfaceIfMissing(quotedType);
> 78: syms.synthesizeEmptyInterfaceIfMissing(quotableType);
> 79: funcOpType = syms.enterClass(jdk_incubator_code, "jdk.incubator.code.op.CoreOp$FuncOp");
Move this close to `opType`
-------------
PR Review: https://git.openjdk.org/babylon/pull/299#pullrequestreview-2518110139
PR Review Comment: https://git.openjdk.org/babylon/pull/299#discussion_r1894258933
More information about the babylon-dev
mailing list