[code-reflection] RFR: Make Quotable a marker interface [v4]

Maurizio Cimadamore mcimadamore at openjdk.org
Wed Jan 8 16:27:19 UTC 2025


On Wed, 8 Jan 2025 13:14:13 GMT, Mourad Abbay <mabbay at openjdk.org> wrote:

>> In this PR, we make Quotable a marker interface. This PR is based on #301.
>
> Mourad Abbay has updated the pull request incrementally with one additional commit since the last revision:
> 
>   Add missing javadoc

src/jdk.incubator.code/share/classes/jdk/incubator/code/Op.java line 499:

> 497:             return Optional.of(q2.quoted());
> 498:         }
> 499:         Method method;

I believe this part is not required? E.g. we can only support cases where the instance implements `Quotable2`. (meaning we know that implementation :-) )

src/jdk.incubator.code/share/classes/jdk/incubator/code/internal/Quotable2.java line 6:

> 4: import jdk.incubator.code.Quoted;
> 5: 
> 6: public interface Quotable2 extends Quotable {

A better name would be preferrable. Maybe `AccessibleQuotable` ?

-------------

PR Review Comment: https://git.openjdk.org/babylon/pull/302#discussion_r1907454127
PR Review Comment: https://git.openjdk.org/babylon/pull/302#discussion_r1907455687


More information about the babylon-dev mailing list