Need reviewers - 6856630: Restructure jaxp repository
Kelly O'Hair
Kelly.Ohair at Sun.COM
Fri Aug 7 23:29:00 UTC 2009
It's still there. javac.debug=true is the default, so the lines:
44 ifeq ($(VARIANT), OPT)
45 ifneq ($(DEBUG_CLASSFILES), true)
46 ANT_OPTIONS += -Djavac.debug=false
47 endif
48 endif
Only set it to false when the build is optimized and DEBUG_CLASSFILES isn't true.
So the end result should be the same.
---
The drop name just dropped into my head :^)
Do you have a better name for it?
-kto
Jonathan Gibbons wrote:
> You've lost these lines: I thought it was a goal to support
> DEBUG_CLASSFILES in all repos
>
> 72 ifeq ($(DEBUG_CLASSFILES), true)
> 73 ANT_OPTIONS += -Djavac.debug=true
> 74 endif
>
>
> Is the "drop" name a standard convention, as compared to, say, "import"?
>
> -- Jon
>
>
>
> Kelly O'Hair wrote:
>>
>> Need reviewers:
>>
>> 6856630: Restructure jaxp/jaxws repositories
>>
>> Webrev: http://cr.openjdk.java.net/~ohair/jdk7/jaxp-6856630/webrev/
>>
>> Goal is to ease the jaxp integration into jdk7.
>> The JAXP team would make the jdk7 source drop bundles available,
>> and integration into jdk7 would involve the modifications of
>> some properties in jaxp/build.properties to use the selected bundles.
>>
>> * 'ant source' populates the drop source and would be run prior to
>> the creation of larger source bundles for openjdk7 and jdk7.
>>
>> * Test bundle specifics and how the tests are run are TBD
>>
>> * Original jaxp source is still in the "src/" directory and after
>> some soak time will be deleted from the repository or moved aside.
>>
>> * Formal builds can use ALT_JAXP_SOURCE_BUNDLE to select the bundle.
>>
>> * The same basic mechanism would be used for jaxws.
>>
>> -kto
>>
>
More information about the build-dev
mailing list