Review Request: 8004803: build-infra: Cannot use icedtea as boot for closed build.

Erik Joelsson erik.joelsson at oracle.com
Wed Dec 12 08:39:45 UTC 2012


What would be a good name for the variable? It's currently setup in 
jdk/makefiles/Setup.gmk as:

JAVAC_JARS ?= 
"-Xbootclasspath/p:$(LANGTOOLS_OUTPUTDIR)/dist/bootstrap/lib/javac.jar" 
-jar $(LANGTOOLS_OUTPUTDIR)/dist/bootstrap/lib/javac.jar

So these are the arguments needed to run the bootstrap javac on the boot 
jdk. Perhaps something like:

BOOTSTRAP_JAVAC
BTJAVAC

But that implies an executable that you can just run and not arguments 
to java. Adding _ARGS at the end implies that it's arguments that you 
give to javac and not the arguments you give to java to launch it. The 
_JARS suffix might look confusing, but I can see where it's coming from. 
Most descriptive might be:

BOOTSTRAP_JAVAC_CLASSPATH_ARGS or
BTJAVAC_CP_ARGS

Anyone has any better ideas?

/Erik

On 2012-12-12 02:56, David Holmes wrote:
> Note that we went from -Xbootclasspath to just -bootclasspath. The 
> former is a VM option and the latter a javac option.
>
> But I agree that JAVAC_JARS is a confusing name.
>
> David
>
> On 12/12/2012 4:47 AM, Kelly O'Hair wrote:
>> Ok, what is confusing me is the name JAVAC_JARS.
>> This not a list of jars, but command line options.  Can we please 
>> rename this variable?
>>
>> -kto
>>
>> On Dec 11, 2012, at 10:42 AM, Tim Bell wrote:
>>
>>> See the message thread on build-infra with subject "Problems with 
>>> non Oracle boot JDKs and class file version 52"
>>>
>>> http://mail.openjdk.java.net/pipermail/build-infra-dev/2012-December/002601.html 
>>>
>>>
>>> The issue appears if the bootstrap VM uses a class file version 
>>> older than what the current build is generating.
>>>
>>> In this particular case, the bootclasspath needs to be supplied to 
>>> javac and not the java running javac.  Changing the order of the 
>>> arguments to be after the javac .jar means javac will process them.
>>>
>>> Tim
>>>
>>>
>>> On 12/11/12 10:20, Kelly O'Hair wrote:
>>>> I don't understand the change.
>>>>
>>>> What is in JAVAC_JARS that changing it's position on the command 
>>>> line makes any difference?
>>>>
>>>> -kto
>>>>
>>>> On Dec 11, 2012, at 5:03 AM, Erik Joelsson wrote:
>>>>
>>>>> This patch corrects the command line for symbol creation.
>>>>>
>>>>> http://cr.openjdk.java.net/~erikj/8004803/webrev.jdk.01/
>>>>>
>>>>> /Erik
>>>
>>>
>>



More information about the build-dev mailing list