Review Request: 7141246 build-infra merge: Introduce new JVM_VARIANT* to control which kind of jvm gets built
Erik Joelsson
erik.joelsson at oracle.com
Mon Mar 12 12:18:38 UTC 2012
http://cr.openjdk.java.net/~erikj/7141246/webrev.01/
<http://cr.openjdk.java.net/%7Eerikj/7141246/webrev.01/>
267 lines changed: 119 ins; 40 del; 108 mod; 4676 unch
7141246 build-infra merge: Introduce new JVM_VARIANT* to control which
kind of jvm gets built
The build-infra project is starting to move into jdk8. For the hotspot
build to stay compatible with the changes, the variables used to control
which kind of jvm gets built needs to be cleaned up. We propose the
following scheme:
JVM_VARIANT={server,client,zero etc}
JVM_VARIANT_SERVER={true,false}
JVM_VARIANT_CLIENT={true,false}
etc.
With this scheme it becomes possible to choose any type of jvm, while
the current scheme can't support only server on 32-bit platform.
Readability in makefile source is much improved with removal of double
negations.
Backwards compatibility is kept by translating the old variables
(ZERO_BUILD, BUILD_ONLY_CLIENT etc) to the new variables in make/defs.gmk.
Additional note: This change will not make all combinations valid or
buildable. However, some previously impossible variations are now
possible, most notably skipping client or kernel on 32-bit hosts.
/Erik
More information about the build-dev
mailing list