Review Request: 8002026: build-infra: deploy repository building
Erik Joelsson
erik.joelsson at oracle.com
Wed Nov 14 09:22:58 UTC 2012
On 2012-11-13 23:06, Tim Bell wrote:
> Hi Erik:
>
>> This is the open part of this change. It only changes the compare
>> script to handle the deploy build artifacts.
>>
>> http://cr.openjdk.java.net/~erikj/8002026/webrev.root.01/
>> <http://cr.openjdk.java.net/%7Eerikj/8002026/webrev.root.01/>
>
> I was getting ready to push this for you when I noticed
> common/bin/compare.sh lines 618 and 624 both test for "windows":
>
> 618 elif [ "$OPENJDK_TARGET_OS" = "windows" ] \
> 619 && [[ "$ACCEPTED_SMALL_SIZE_DIFF" = *"$BIN_FILE"* ]] \
> 620 && [ "$DIFF_SIZE_NUM" = 512 ]; then
> 621 # On windows, size of binaries increase in 512
> increments.
> 622 SIZE_MSG="($SIZE_MSG)"
> 623 DIFF_SIZE=
> 624 elif [ "$OPENJDK_TARGET_OS" = "windows" ] \
> 625 && [[ "$ACCEPTED_SMALL_SIZE_DIFF" = *"$BIN_FILE"* ]] \
> 626 && [ "$DIFF_SIZE_NUM" = -512 ]; then
> 627 # On windows, size of binaries increase in 512
> increments.
> 628 SIZE_MSG="($SIZE_MSG)"
> 629 DIFF_SIZE=
>
>
> Is that what you wanted, or is one of those intended for macos as it
> is used later on with line 1232?
>
>
Yes, it's intended. What I really would like to express is (in pseudo code):
if (OS=windows AND BIN_FILE in ACCEPTED_SIZE_DIFF AND (DIFF_SIZE_NUM =
512 OR DIFF_SIZE_NUM = -512))
I wasn't sure I could write this in bash, but maybe I'm wrong. I figured
this would be more readable anyway.
/Erik
More information about the build-dev
mailing list