AIX xlc16 options langlvl=c99vla / langlvl=noredefmac is not supported

Baesken, Matthias matthias.baesken at sap.com
Mon Jul 8 07:22:08 UTC 2019


Hello,   when building   jdk/jdk  on AIX  (using the current default xlc16)   I get a ton of warnings  :

warning: 1540-5200 The option "langlvl=c99vla" is not supported.
warning: 1540-5200 The option "langlvl=noredefmac" is not supported.


The 2  options seem  to be gone with the current xlc16  / xlclang++  .   I would like to remove them -  any objections ?
(removing them might be bad for older xlc  versions but I think we  probably  cannot compile with older versions  any more  ) .


Best regards, Matthias


More information about the build-dev mailing list