RFR: 8275063: Implementation of Foreign Function & Memory API (Second incubator) [v26]
Maurizio Cimadamore
mcimadamore at openjdk.java.net
Mon Nov 22 12:09:30 UTC 2021
> This PR contains the API and implementation changes for JEP-419 [1]. A more detailed description of such changes, to avoid repetitions during the review process, is included as a separate comment.
>
> [1] - https://openjdk.java.net/jeps/419
Maurizio Cimadamore has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 35 commits:
- Merge branch 'master' into JEP-419
- Fix javadoc issues found in CSR review
- Adopt blessed modofier order
- Merge branch 'master' into JEP-419
- Revert removal of upcall MH customization
(This change caused spurious VM crashes, so reverting to baseline)
- Further tweak upcall safety considerations
- Clarify safety considerations for upcalls
- Rename MemorySegment::ofAddressNative to MemorySegment::ofAddress
(which is consistent with other restricted factories in VaList and NativeSymbol)
- Streamline javadoc for package-info
- * Add two new CLinker static methods to compute upcall/downcall method types
* Clarify section on CLinker downcall type
* Add section on CLinker safety guarantees
- ... and 25 more: https://git.openjdk.java.net/jdk/compare/d427c79d...29cc6c60
-------------
Changes: https://git.openjdk.java.net/jdk/pull/5907/files
Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=5907&range=25
Stats: 14700 lines in 193 files changed: 6958 ins; 5126 del; 2616 mod
Patch: https://git.openjdk.java.net/jdk/pull/5907.diff
Fetch: git fetch https://git.openjdk.java.net/jdk pull/5907/head:pull/5907
PR: https://git.openjdk.java.net/jdk/pull/5907
More information about the build-dev
mailing list