RFR: 8277204: Implement PAC-RET branch protection on Linux/AArch64 [v18]
Alan Hayward
duke at openjdk.java.net
Mon Feb 7 11:46:21 UTC 2022
On Mon, 7 Feb 2022 10:57:15 GMT, Andrew Haley <aph at openjdk.org> wrote:
>> src/hotspot/cpu/aarch64/macroAssembler_aarch64.cpp line 5293:
>>
>>> 5291: // Create an additional frame for a function.
>>> 5292: void MacroAssembler::enter_subframe() {
>>> 5293: // Addresses can only be signed once, so strip it first. PAC safe because the value is not
>>
>> This needs a more descriptive name. `enter_and_sign()` ? No, that's not right either. How do we come up with a name that's more descriptive?
>
> Because enter always enters a subframe. That's what it's for.
enter_nested() ?
enter_inner() ?
-------------
PR: https://git.openjdk.java.net/jdk/pull/6334
More information about the build-dev
mailing list