RFR: 8319818: Address GCC 13.2.0 warnings (stringop-overflow and dangling-pointer)
Magnus Ihse Bursie
ihse at openjdk.org
Thu Nov 9 17:54:59 UTC 2023
On Thu, 9 Nov 2023 16:07:53 GMT, Mikael Vidstedt <mikael at openjdk.org> wrote:
> This PR is splitting out the GCC 13.2.0 warning related changes from #16550, excluding the Oracle/devkit parts, for clarity and to make potential backports more straightforward.
>
> GCC 13.2.0 generates two new warnings:
>
> * linux-aarch64-debug
>
> src/hotspot/os_cpu/linux_aarch64/atomic_linux_aarch64.hpp:203:66: error: 'long unsigned int __atomic_load_8(const volatile void*, int)' writing 8 bytes into a region of size 0 overflows the destination [-Werror=stringop-overflow=]
>
> I did not find any way to adjust the code to avoid this warning, so I instead chose to disable it in `CompileJvm.gmk` for linux-aarch64-(fast)debug only.
>
> * linux-zero
>
> src/hotspot/share/runtime/thread.hpp:579:77: error: storing the address of local variable 'rm' in '*_thr_current.Thread::_current_resource_mark' [-Werror=dangling-pointer=]
>
> Lots and lots of warnings related to ResourceMark. Thanks to @stefank for suggesting moving the ASSERT implementation of the ResourceMark constructor to the .cpp file. With that change there's no need to explicitly disable the warning.
Just to be a nuisance: I think the flag changes belong in the original PR, and that *just* the code changes should be here. (This is also how I interpret David's comment.)
The code change will resolve a warning (that only shows with an upgraded compiler). The flag is about disabling a different warning that is relevant when upgrading the compiler.
-------------
PR Comment: https://git.openjdk.org/jdk/pull/16584#issuecomment-1804292400
More information about the build-dev
mailing list