RFR: 8329704: Implement framework for proper handling of JDK_LIBS [v7]
Magnus Ihse Bursie
ihse at openjdk.org
Wed Apr 10 14:50:01 UTC 2024
On Wed, 10 Apr 2024 14:43:26 GMT, Magnus Ihse Bursie <ihse at openjdk.org> wrote:
>> This is the pinnacle of the recent stream of refactorings in the build system. This patch introduces a more abstract concept of "JDK_LIBS", where only the library name (e.g. "java" or "java.desktop:jawt") is specified, and the build system turns this into suitable linker flags: `-ljawt -L<correct path>` or `jawt.lib -libpath:<correct path>`, depending on linker. It will also automatically create proper dependencies.
>
> Magnus Ihse Bursie has updated the pull request incrementally with one additional commit since the last revision:
>
> Remove extra blank line
I'm glad we agreed on the new syntax. It aligns nicely with the existing SRC syntax, and there is no ambiguity or symbols like `@` with special meaning (I was not fond of that either, but could not figure out a better way to mimic the old syntax). It is a bit longer, and a line like this is a bit hard to read:
JDK_LIBS := java.base:libjava java.base:libjli java.base:libjvm, \
but I guess that is a price we just have to pay.
-------------
PR Comment: https://git.openjdk.org/jdk/pull/18649#issuecomment-2047760454
More information about the build-dev
mailing list