RFR: JDK-8298405: Support Markdown in Documentation Comments [v7]
Jonathan Gibbons
jjg at openjdk.org
Tue Jan 30 19:31:40 UTC 2024
On Mon, 22 Jan 2024 15:35:41 GMT, Pavel Rappo <prappo at openjdk.org> wrote:
>> Jonathan Gibbons has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains eight commits:
>>
>> - Merge with upstream/master
>> - Merge with upstream/master
>> - Merge remote-tracking branch 'upstream/master' into 8298405.doclet-markdown-v3
>> - Address review comments
>> - Fix whitespace
>> - Improve handling of embedded inline taglets
>> - Customize support for Markdown headings
>> - JDK-8298405: Support Markdown in Documentation Comments
>
> src/jdk.compiler/share/classes/com/sun/tools/javac/parser/DocCommentParser.java line 271:
>
>> 269: // if (textStart == -1) {
>> 270: // textStart = bp;
>> 271: // }
>
> What's up with that?
It was a temporary senior moment, attempting to trim the content of the comment -- but the leading whitespace is significant and should not be removed. The lines have been removed.
> src/jdk.compiler/share/classes/com/sun/tools/javac/parser/DocCommentParser.java line 1165:
>
>> 1163: }
>> 1164:
>> 1165:
>
> Please delete this blank line.
Done
> src/jdk.compiler/share/classes/com/sun/tools/javac/parser/DocCommentParser.java line 1333:
>
>> 1331: lineKind = (ch == '\n' || ch == '\r') ? LineKind.BLANK
>> 1332: : (indent <= 3) ? peekLineKind()
>> 1333: : LineKind.OTHER;
>
> Nested ternary-s are hard to read. Nested if-s are bulky. Sigh.
That was the neatest I could make it ;-)
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/16388#discussion_r1471829709
PR Review Comment: https://git.openjdk.org/jdk/pull/16388#discussion_r1471831762
PR Review Comment: https://git.openjdk.org/jdk/pull/16388#discussion_r1471830921
More information about the build-dev
mailing list