RFR: 8329086: Clean up java.desktop native compilation

Erik Joelsson erikj at openjdk.org
Tue Mar 26 23:24:24 UTC 2024


On Tue, 26 Mar 2024 12:51:38 GMT, Magnus Ihse Bursie <ihse at openjdk.org> wrote:

> This is a follow-up on [JDK-8328680](https://bugs.openjdk.org/browse/JDK-8328680), making the same kind of cleanup to java.desktop. Some code needed more special treatment here, so there is some additional effects outside of the modules/java.desktop directory. The code was also in worse shape than other modules, so some additional changes to the build logic where needed.

make/autoconf/lib-bundled.m4 line 107:

> 105: 
> 106:     USE_EXTERNAL_LIBGIF=true
> 107:     GIFLIB_LIBS=-lgif

GIFLIB vs LIBGIF? Just above we have LIBJPEG. Should we stick to one naming convention, or did you want to avoid changing any variable names?

make/modules/java.desktop/lib/Awt2dLibraries.gmk line 127:

> 125:     CFLAGS := $(X_CFLAGS) $(LIBAWT_CFLAGS), \
> 126:     CFLAGS_gcc := -fgcse-after-reload, \
> 127:     CXXFLAGS := $(LIBAWT_CFLAGS) $(X_CFLAGS), \

Is the reverse ordering of flags for CXXFLAGS an accident?

make/modules/java.desktop/lib/Awt2dLibraries.gmk line 588:

> 586: 
> 587: ifeq ($(call isTargetOs, macosx), true)
> 588:   # libjawt on macosx do not use the unix code

Suggestion:

  # libjawt on macosx does not use the unix code

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/18486#discussion_r1540161296
PR Review Comment: https://git.openjdk.org/jdk/pull/18486#discussion_r1540172539
PR Review Comment: https://git.openjdk.org/jdk/pull/18486#discussion_r1540221866


More information about the build-dev mailing list