RFR: 8304915: Create jdk.internal.util.Architecture enum and apply [v2]

Glavo duke at openjdk.org
Wed Apr 5 18:55:19 UTC 2023


On Wed, 5 Apr 2023 18:53:12 GMT, Roger Riggs <rriggs at openjdk.org> wrote:

>> Define an internal jdk.internal.util.Architecture enumeration and static methods to replace uses of the system property `os.arch`.
>> The enumeration values are defined to match those used in the build.
>> The initial values are: `X64, X86, IA64, ARM, AARCH64, RISCV64, S390X, PPC64LE`
>> Note that `amd64` and `x86_64` in the build are represented by `X64`.
>> The values of the system property `os.arch` is unchanged.
>> 
>> The API is similar to the jdk.internal.util.OperatingSystem enum created by #[12931](https://git.openjdk.org/jdk/pull/12931).
>> Uses in `java.base` and a few others are included but other modules will be done in separate PRs.
>
> Roger Riggs has updated the pull request incrementally with one additional commit since the last revision:
> 
>   Rename isXXX method to be uppercase architecture names matching the enum.
>   Refactor the is64Bit method to be a static method for the current runtime.

src/java.base/share/classes/jdk/internal/util/Architecture.java line 85:

> 83:      */
> 84:     @ForceInline
> 85:     public static boolean isRISCV() {

I think it should be named `isRISCV64` because RISC-V also has a 32-bit variant, so the name `isRISCV` may cause confusion.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/13357#discussion_r1158897476



More information about the client-libs-dev mailing list