RFR: 8342782: AWTEventMulticaster throws StackOverflowError using AquaButtonUI

Laurent Bourgès lbourges at openjdk.org
Sat Nov 23 10:03:17 UTC 2024


On Thu, 7 Nov 2024 21:36:27 GMT, Phil Race <prr at openjdk.org> wrote:

>> The AWTEventMulticaster is a tree node with 2 children. This PR proposes rebalancing that tree after 500 additions to avoid potential StackOverflowErrors when trying to interact with a large AWTEventMulticaster.
>> 
>> In the original headful test:
>> We added 8,000 checkboxes, and when their parent panel was hidden the stack needed to grow to 24,000 lines. It took 8,000 lines to recursively call `java.awt.AWTEventMulticaster.componentHidden`, and then 16,000 additional lines to call two recursive methods to remove a listener:
>> 
>> java.desktop/java.awt.AWTEventMulticaster.removeInternal()
>> java.desktop/java.awt.AWTEventMulticaster.remove()
>> 
>> 
>> With this current PR the max stack size reaches 1,267 instead. (If we rebalanced at EVERY addition, then that same scenario would reach a max stack size of 71.)
>> 
>> JDK-8342782 included a headful test case, but I think the main problem it demonstrated can be represented by the headless test case attached to this PR.
>> 
>> Depending on how this PR is received I may submit a separate ticket & PR to modify AquaButtonUI so it doesn't always attach an AncestorListener. (That is: if my GUI includes 8,000 checkboxes then I don't need 8,000 AncestorListeners.) But JDK-8342782's test case is currently written in a way that should reproduce across all L&F's, so that can be discussed separately.
>
> src/java.desktop/share/classes/java/awt/AWTEventMulticaster.java line 991:
> 
>> 989:         while (true) {
>> 990:             if (++level > 500)
>> 991:                 return true;
> 
> our coding standards require that you always include the body in { .. }

500 is magic number ?
I recommend using a constant explaining how this magic value has been determined empirically ?

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/21962#discussion_r1855148234


More information about the client-libs-dev mailing list