From Leonid.Kuskov at Oracle.com Tue Sep 11 20:40:13 2018 From: Leonid.Kuskov at Oracle.com (Leonid Kuskov) Date: Tue, 11 Sep 2018 13:40:13 -0700 Subject: RFR: CODETOOLS-7902316: jdis ignores exception_table entries and uses a wrong format for iinc_w instruction Message-ID: Bug: https://bugs.openjdk.java.net/browse/CODETOOLS-7902316 Webrev: http://cr.openjdk.java.net/~lkuskov/7902316/webrev.00 Trivial fix for "an 'iinc_w 263;' is produced, with the second iinc argument missing.": --- a/src/org/openjdk/asmtools/jdis/CodeData.java?????? Thu May 17 13:34:08 2018 -0700 +++ b/src/org/openjdk/asmtools/jdis/CodeData.java?????? Tue Sep 11 13:08:21 2018 -0700 @@ -422,7 +422,7 @@ ???????????????????? mnem = opcode2.parsekey(); ???????????????? } ???????????????? out.print(mnem + " " + getUShort(pc + 2)); -??????????????? if (opcode2 == Opcode.opc_iinc) { +??????????????? if (opcode2 == Opcode.opc_iinc_w) { ???????????????????? out.print(", " + getShort(pc + 4)); ???????????????????? return 6; ???????????????? } The fix for "Also, two 'endtry' and 'catch' are missing after this iinc_w.": asmtools loses start_pc/end_pc item/handler_pc if it exceeds Short.MAX_VALUE --- a/src/org/openjdk/asmtools/jdis/TrapData.java?????? Thu May 17 13:34:08 2018 -0700 +++ b/src/org/openjdk/asmtools/jdis/TrapData.java?????? Tue Sep 11 13:08:21 2018 -0700 ?class TrapData { -??? short start_pc, end_pc, handler_pc, catch_cpx; ???? int num; +??? // exception_table +??? int start_pc,?????? // u2 +??????? end_pc,???????? // u2 +??????? handler_pc,???? // u2 +??????? catch_cpx;????? // u2 + ???? public TrapData(DataInputStream in, int num) throws IOException { ???????? this.num = num; -??????? start_pc = in.readShort(); -??????? end_pc = in.readShort(); -??????? handler_pc = in.readShort(); -??????? catch_cpx = in.readShort(); +??????? start_pc = in.readUnsignedShort(); +??????? end_pc = in.readUnsignedShort(); +??????? handler_pc = in.readUnsignedShort(); +??????? catch_cpx = in.readUnsignedShort(); Thanks, Leonid From alexandre.iline at oracle.com Fri Sep 14 18:26:35 2018 From: alexandre.iline at oracle.com (Alexandre (Shura) Iline) Date: Fri, 14 Sep 2018 11:26:35 -0700 Subject: RFR: CODETOOLS-7902316: jdis ignores exception_table entries and uses a wrong format for iinc_w instruction In-Reply-To: References: Message-ID: Looks good, Leonid. Shura > On Sep 11, 2018, at 1:40 PM, Leonid Kuskov wrote: > > Bug: https://bugs.openjdk.java.net/browse/CODETOOLS-7902316 > Webrev: http://cr.openjdk.java.net/~lkuskov/7902316/webrev.00 > > Trivial fix for "an 'iinc_w 263;' is produced, with the second iinc argument missing.": > > --- a/src/org/openjdk/asmtools/jdis/CodeData.java Thu May 17 13:34:08 2018 -0700 > +++ b/src/org/openjdk/asmtools/jdis/CodeData.java Tue Sep 11 13:08:21 2018 -0700 > > @@ -422,7 +422,7 @@ > mnem = opcode2.parsekey(); > } > out.print(mnem + " " + getUShort(pc + 2)); > - if (opcode2 == Opcode.opc_iinc) { > + if (opcode2 == Opcode.opc_iinc_w) { > out.print(", " + getShort(pc + 4)); > return 6; > } > > The fix for "Also, two 'endtry' and 'catch' are missing after this iinc_w.": > > asmtools loses start_pc/end_pc item/handler_pc if it exceeds Short.MAX_VALUE > > --- a/src/org/openjdk/asmtools/jdis/TrapData.java Thu May 17 13:34:08 2018 -0700 > +++ b/src/org/openjdk/asmtools/jdis/TrapData.java Tue Sep 11 13:08:21 2018 -0700 > > class TrapData { > > - short start_pc, end_pc, handler_pc, catch_cpx; > int num; > > + // exception_table > + int start_pc, // u2 > + end_pc, // u2 > + handler_pc, // u2 > + catch_cpx; // u2 > + > public TrapData(DataInputStream in, int num) throws IOException { > this.num = num; > - start_pc = in.readShort(); > - end_pc = in.readShort(); > - handler_pc = in.readShort(); > - catch_cpx = in.readShort(); > + start_pc = in.readUnsignedShort(); > + end_pc = in.readUnsignedShort(); > + handler_pc = in.readUnsignedShort(); > + catch_cpx = in.readUnsignedShort(); > > Thanks, > Leonid > > From tim.bell at oracle.com Thu Sep 20 02:32:02 2018 From: tim.bell at oracle.com (Tim Bell) Date: Thu, 20 Sep 2018 02:32:02 +0000 Subject: RFR for CODETOOLS-7902292: defpath extension broken after util.Abort removed from hg in March 2018 Message-ID: <5BA306A2.7030706@oracle.com> Hello Abort() was moved/copied from util to error in hg 1.3 and was removed from util in hg 4.6 This is the same fix used on trees.py back in July [1]. http://cr.openjdk.java.net/~tbell/CODETOOLS-7902292/webrev/ Tested with hg versions 3.2.3, 4.7 Thanks in advance. I will also need a sponsor to push the change for me. Tim [1] Ref lines 140 ... 146: http://hg.openjdk.java.net/code-tools/trees/comparison/592eba45b774/trees.py From tim.bell at oracle.com Thu Sep 20 04:47:43 2018 From: tim.bell at oracle.com (Tim Bell) Date: Thu, 20 Sep 2018 04:47:43 +0000 Subject: RFR for CODETOOLS-7902293 and 7902317 jcheck extension broken in recent builds of hg Message-ID: <5BA3266F.8030602@oracle.com> Hello Two changes in recent builds of hg broke jcheck: 1) CODETOOLS-7902292: util.Abort() was moved/copied from util to error in hg 1.3 and was removed from util in 4.6. This is the same fix used on trees.py back in July [1]. 2) CODETOOLS-7902317: date-related utils moved from util to utils/dateutil in early 2018 (hg 4.7). http://cr.openjdk.java.net/~tbell/CODETOOLS-7902293-7902317/webrev/ Tested with hg versions 0.9.5, 2.9, 3.2.3, 4.7 Thanks in advance. I will also need a sponsor to push the change for me. Tim [1] Ref lines 140 ... 146: http://hg.openjdk.java.net/code-tools/trees/comparison/592eba45b774/trees.py From magnus.ihse.bursie at oracle.com Thu Sep 20 08:39:08 2018 From: magnus.ihse.bursie at oracle.com (Magnus Ihse Bursie) Date: Thu, 20 Sep 2018 10:39:08 +0200 Subject: RFR for CODETOOLS-7902292: defpath extension broken after util.Abort removed from hg in March 2018 In-Reply-To: <5BA306A2.7030706@oracle.com> References: <5BA306A2.7030706@oracle.com> Message-ID: <3106af26-ab4a-7def-9eb8-9f972b6f6bcf@oracle.com> On 2018-09-20 04:32, Tim Bell wrote: > Hello > > Abort() was moved/copied from util to error in hg 1.3 and was removed > from util in hg 4.6 > > This is the same fix used on trees.py back in July [1]. > > http://cr.openjdk.java.net/~tbell/CODETOOLS-7902292/webrev/ Looks good to me. (I am not a formal Reviewer) /Magnus > > Tested with hg versions 3.2.3, 4.7 > > Thanks in advance.? I will also need a sponsor to push the change for me. > > Tim > > [1] Ref lines 140 ... 146: > http://hg.openjdk.java.net/code-tools/trees/comparison/592eba45b774/trees.py From magnus.ihse.bursie at oracle.com Thu Sep 20 08:42:00 2018 From: magnus.ihse.bursie at oracle.com (Magnus Ihse Bursie) Date: Thu, 20 Sep 2018 10:42:00 +0200 Subject: RFR for CODETOOLS-7902293 and 7902317 jcheck extension broken in recent builds of hg In-Reply-To: <5BA3266F.8030602@oracle.com> References: <5BA3266F.8030602@oracle.com> Message-ID: On 2018-09-20 06:47, Tim Bell wrote: > Hello > > Two changes in recent builds of hg broke jcheck: > > 1) CODETOOLS-7902292: util.Abort() was moved/copied from util to error > in hg 1.3 and was removed from util in 4.6.? This is the same fix used > on trees.py back in July [1]. > > 2) CODETOOLS-7902317: date-related utils moved from util to > utils/dateutil in early 2018 (hg 4.7). > > http://cr.openjdk.java.net/~tbell/CODETOOLS-7902293-7902317/webrev/ Basically looks good. (But I'm still not a formal Reviewer :-()) However, I'm thinking that -- in line with the name error_Abort for error.Abort -- maybe an even better name than datestr_F would be dateutil_datestr? The "_F" part (for function?) looks a bit odd. /Magnus > > Tested with hg versions 0.9.5, 2.9, 3.2.3, 4.7 > > Thanks in advance.? I will also need a sponsor to push the change for me. > > Tim > > [1] Ref lines 140 ... 146: > http://hg.openjdk.java.net/code-tools/trees/comparison/592eba45b774/trees.py > From tim.bell at oracle.com Thu Sep 20 14:14:01 2018 From: tim.bell at oracle.com (Tim Bell) Date: Thu, 20 Sep 2018 14:14:01 +0000 Subject: RFR for CODETOOLS-7902293 and 7902317 jcheck extension broken in recent builds of hg In-Reply-To: References: <5BA3266F.8030602@oracle.com> Message-ID: <5BA3AB29.2020309@oracle.com> Magnus: > On 2018-09-20 06:47, Tim Bell wrote: >> Hello >> >> Two changes in recent builds of hg broke jcheck: >> >> 1) CODETOOLS-7902292: util.Abort() was moved/copied from util to error >> in hg 1.3 and was removed from util in 4.6. This is the same fix used >> on trees.py back in July [1]. >> >> 2) CODETOOLS-7902317: date-related utils moved from util to >> utils/dateutil in early 2018 (hg 4.7). >> >> http://cr.openjdk.java.net/~tbell/CODETOOLS-7902293-7902317/webrev/ > > Basically looks good. (But I'm still not a formal Reviewer :-()) > > However, I'm thinking that -- in line with the name error_Abort for > error.Abort -- maybe an even better name than datestr_F would be > dateutil_datestr? The "_F" part (for function?) looks a bit odd. Yes, it was for function. Thanks for the suggestion - I was struggling with the name and decided to go with what I had. I like your name better. New webrev: http://cr.openjdk.java.net/~tbell/CODETOOLS-7902293-7902317/01/webrev/ Tim > > /Magnus > >> >> Tested with hg versions 0.9.5, 2.9, 3.2.3, 4.7 >> >> Thanks in advance. I will also need a sponsor to push the change for me. >> >> Tim >> >> [1] Ref lines 140 ... 146: >> http://hg.openjdk.java.net/code-tools/trees/comparison/592eba45b774/trees.py >> > From magnus.ihse.bursie at oracle.com Thu Sep 20 18:51:09 2018 From: magnus.ihse.bursie at oracle.com (Magnus Ihse Bursie) Date: Thu, 20 Sep 2018 20:51:09 +0200 Subject: RFR for CODETOOLS-7902293 and 7902317 jcheck extension broken in recent builds of hg In-Reply-To: <5BA3AB29.2020309@oracle.com> References: <5BA3266F.8030602@oracle.com> <5BA3AB29.2020309@oracle.com> Message-ID: <39d07aca-ad3e-174b-0e1a-38e8584984d9@oracle.com> On 2018-09-20 16:14, Tim Bell wrote: > Magnus: > >> On 2018-09-20 06:47, Tim Bell wrote: >>> Hello >>> >>> Two changes in recent builds of hg broke jcheck: >>> >>> 1) CODETOOLS-7902292: util.Abort() was moved/copied from util to error >>> in hg 1.3 and was removed from util in 4.6.? This is the same fix used >>> on trees.py back in July [1]. >>> >>> 2) CODETOOLS-7902317: date-related utils moved from util to >>> utils/dateutil in early 2018 (hg 4.7). >>> >>> http://cr.openjdk.java.net/~tbell/CODETOOLS-7902293-7902317/webrev/ >> >> Basically looks good. (But I'm still not a formal Reviewer :-()) >> >> However, I'm thinking that -- in line with the name error_Abort for >> error.Abort -- maybe an even better name than datestr_F would be >> dateutil_datestr? The "_F" part (for function?) looks a bit odd. > > Yes, it was for function.? Thanks for the suggestion - I was > struggling with the name and decided to go with what I had. > > I like your name better.? New webrev: > > http://cr.openjdk.java.net/~tbell/CODETOOLS-7902293-7902317/01/webrev/ LGTM. /Magnus > > Tim > >> >> /Magnus >> >>> >>> Tested with hg versions 0.9.5, 2.9, 3.2.3, 4.7 >>> >>> Thanks in advance.? I will also need a sponsor to push the change >>> for me. >>> >>> Tim >>> >>> [1] Ref lines 140 ... 146: >>> http://hg.openjdk.java.net/code-tools/trees/comparison/592eba45b774/trees.py >>> >>> >> > From jonathan.gibbons at oracle.com Fri Sep 21 17:05:06 2018 From: jonathan.gibbons at oracle.com (Jonathan Gibbons) Date: Fri, 21 Sep 2018 10:05:06 -0700 Subject: CFV: New Code Tools Committer: Tim Bell Message-ID: <5BA524C2.7080402@oracle.com> I hereby nominate Tim Bell to Code Tools Committer. Although Tim is not a frequent contributor to the Code Tools project, he has contributed to the smaller repos containing Mercurial tools such as defpath, jcheck and trees, as well as webrev, and he has considerable experience as a Committer and Reviewer in his work as a member of the build team. Votes are due by 10 a.m. PDT, Oct 5. Only current Code Tools Committers [1] are eligible to vote on this nomination. Votes must be cast in the open by replying to this mailing list. For Lazy Consensus voting instructions, see [2]. Jonathan Gibbons [1] http://openjdk.java.net/census [2] http://openjdk.java.net/projects/#committer-vote| From iris.clark at oracle.com Mon Sep 24 19:41:28 2018 From: iris.clark at oracle.com (Iris Clark) Date: Mon, 24 Sep 2018 12:41:28 -0700 (PDT) Subject: CFV: New Code Tools Committer: Tim Bell In-Reply-To: <5BA524C2.7080402@oracle.com> References: <5BA524C2.7080402@oracle.com> Message-ID: Vote: yes Thanks, iris From erik.joelsson at oracle.com Mon Sep 24 23:30:07 2018 From: erik.joelsson at oracle.com (Erik Joelsson) Date: Mon, 24 Sep 2018 16:30:07 -0700 Subject: CFV: New Code Tools Committer: Tim Bell In-Reply-To: <5BA524C2.7080402@oracle.com> References: <5BA524C2.7080402@oracle.com> Message-ID: <7b010e48-bf9a-a029-884e-841ee4340702@oracle.com> Vote: yes /Erik On 2018-09-21 10:05, Jonathan Gibbons wrote: > I hereby nominate Tim Bell to Code Tools Committer. > > Although Tim is not a frequent contributor to the Code Tools project, > he has contributed to the smaller repos containing Mercurial tools > such as defpath, jcheck and trees, as well as webrev, and he has > considerable experience as a Committer and Reviewer in his work as > a member of the build team. > > Votes are due by 10 a.m. PDT, Oct 5. > > Only current Code Tools Committers [1] are eligible to vote > on this nomination.? Votes must be cast in the open by replying > to this mailing list. > > For Lazy Consensus voting instructions, see [2]. > > Jonathan Gibbons > > [1] http://openjdk.java.net/census > [2] http://openjdk.java.net/projects/#committer-vote| From jonathan.gibbons at oracle.com Mon Sep 24 23:32:44 2018 From: jonathan.gibbons at oracle.com (Jonathan Gibbons) Date: Mon, 24 Sep 2018 16:32:44 -0700 Subject: CFV: New Code Tools Committer: Tim Bell In-Reply-To: <5BA524C2.7080402@oracle.com> References: <5BA524C2.7080402@oracle.com> Message-ID: <5BA9741C.5030209@oracle.com> Vote: yes On 09/21/2018 10:05 AM, Jonathan Gibbons wrote: > I hereby nominate Tim Bell to Code Tools Committer. > > Although Tim is not a frequent contributor to the Code Tools project, > he has contributed to the smaller repos containing Mercurial tools > such as defpath, jcheck and trees, as well as webrev, and he has > considerable experience as a Committer and Reviewer in his work as > a member of the build team. > > Votes are due by 10 a.m. PDT, Oct 5. > > Only current Code Tools Committers [1] are eligible to vote > on this nomination. Votes must be cast in the open by replying > to this mailing list. > > For Lazy Consensus voting instructions, see [2]. > > Jonathan Gibbons > > [1] http://openjdk.java.net/census > [2] http://openjdk.java.net/projects/#committer-vote|