VERSION 2: Re: Proposal: Type inference for variable definition/initialization using the 'auto' keyword.

Brendon McLean java.net at twistedprotein.com
Tue May 26 09:08:04 PDT 2009


On 26 May 2009, at 14:25, Ruslan Shevchenko wrote:
> Economically, value of code owning is mostly cost of reading than
> cost of writing. I. e. I think 'IDE can do this' is not very valuable
> argument.

Traditionally so, but IDEs are on their way to addressing the  
readability aspect too.  The upcoming early access of IntelliJ IDEA  
can code fold:

fillMap(Collections.<String, List<Integer>>emptyMap());

to:

fillMap(Collections.<~>emptyMap());

Expect the herd to follow.  (likewise, anonymous inner classes can  
fold too and I can pretend that a closures proposal succeeded).

I realise there's a purity issue here; one shouldn't need an IDE to  
make head or tail of code.  But personally, I would rather Java ages  
gracefully and look at my code through ruby-tinted IDE goggles than  
make changes which compromise Java's simplicity.

Regards,
Brendon. 
  



More information about the coin-dev mailing list