trying out the prototype
Howard Lovatt
howard.lovatt at gmail.com
Tue Aug 24 21:41:39 PDT 2010
Zhong Yu,
This idea, auto closing when the variable goes out of scope, was
discussed reasonably thoroughly much earlier in the Project Coin
cycle. I thought it was the best solution however others, who have a
vote unlike me, preferred the try block solution.
-- Howard.
Zhong Yu zhong.j.yu at gmail.com Tue Aug 24 11:37:23 PDT 2010 wrote:
How about this:
// any block
{
int c;
try FileReader reader = new FileReader( source );
try FileWriter writer = new FileWriter( target );
while( (c = reader.read()) != -1 )
writer.write(c);
}
The [try ResourceSpecification] statement can appear anywhere in a
block. When the enclosing block completes, close() methods are
invoked.
It's almost as if we have destructors
public void copy(File source, File target) throws IOException
{
int c;
try FileReader reader = new FileReader( source );
try FileWriter writer = new FileWriter( target );
while( (c = reader.read()) != -1 )
writer.write(c);
} // reader and writer will be closed upon method completion
Since we piggyback it on an existing block, we can avoid one
indentation, and making code more readable. Compatibility isn't
broken, the new behavior of the block only arise if the new type of
statement appears inside.
The "try" keyword probably sounds unnatural for this purpose. Maybe we
can use some other keyword or symbol.
IDE should warn when it appears that an auto-closeable resource is
not, but should be, initialized this way.
Note, the auto-close behavior stays the same even if the enclosing
block is a try block
try
{
int c;
try FileReader reader = new FileReader( source );
try FileWriter writer = new FileWriter( target );
while( (c = reader.read()) != -1 )
writer.write(c);
}
catch(IOException e)
{
// reader and writer already closed!
}
Zhong Yu
More information about the coin-dev
mailing list