RFR 8054474: Add --state-dir=bar to sjavac
Fredrik Öhrström
oehrstroem at gmail.com
Fri Aug 8 19:07:28 UTC 2014
+ String idOpt = Util.extractStringOption("id",
javacService.serverSettings());
> final String id = idOpt;
>
Leftover from the old code. Now fixed.
Perhaps the following variables could have more descriptive names.
>
> + String s = options.getServerConf();
> + String se = (s!=null)? s : "";
> + String i = Util.extractStringOption("id", se);
>
> Fixed.
> Do we have to bundle up the settings in a *String*? I'd prefea more
> typesafe datastructure.
>
>
See https://bugs.openjdk.java.net/browse/JDK-8054690
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openjdk.java.net/pipermail/compiler-dev/attachments/20140808/fb420f89/attachment-0001.html>
More information about the compiler-dev
mailing list