From jonathan.gibbons at oracle.com Thu Jul 14 17:08:59 2016 From: jonathan.gibbons at oracle.com (Jonathan Gibbons) Date: Thu, 14 Jul 2016 10:08:59 -0700 Subject: RFR: (tiny) 8071484 fix comment in DCReference Message-ID: <5787C72B.3060506@oracle.com> Please review this small change to an out-of-date comment in DCTree.java diff -r 078810545cd5 src/jdk.compiler/share/classes/com/sun/tools/javac/tree/DCTree.java --- a/src/jdk.compiler/share/classes/com/sun/tools/javac/tree/DCTree.java Thu Jul 14 16:21:39 2016 +0000 +++ b/src/jdk.compiler/share/classes/com/sun/tools/javac/tree/DCTree.java Thu Jul 14 09:50:44 2016 -0700 @@ -578,7 +578,7 @@ public final String signature; // The following are not directly exposed through ReferenceTree - // use DocTrees.getElement(TreePath,ReferenceTree) + // use DocTrees.getElement(DocTreePath) public final JCTree qualifierExpression; public final Name memberName; public final List paramTypes; JBS: https://bugs.openjdk.java.net/browse/JDK-8071484 -- Jon From joe.darcy at oracle.com Thu Jul 14 17:10:43 2016 From: joe.darcy at oracle.com (Joseph D. Darcy) Date: Thu, 14 Jul 2016 10:10:43 -0700 Subject: RFR: (tiny) 8071484 fix comment in DCReference In-Reply-To: <5787C72B.3060506@oracle.com> References: <5787C72B.3060506@oracle.com> Message-ID: <5787C793.6000407@oracle.com> +1 -Joe On 7/14/2016 10:08 AM, Jonathan Gibbons wrote: > Please review this small change to an out-of-date comment in DCTree.java > > diff -r 078810545cd5 > src/jdk.compiler/share/classes/com/sun/tools/javac/tree/DCTree.java > --- > a/src/jdk.compiler/share/classes/com/sun/tools/javac/tree/DCTree.java > Thu Jul 14 16:21:39 2016 +0000 > +++ > b/src/jdk.compiler/share/classes/com/sun/tools/javac/tree/DCTree.java > Thu Jul 14 09:50:44 2016 -0700 > @@ -578,7 +578,7 @@ > public final String signature; > > // The following are not directly exposed through ReferenceTree > - // use DocTrees.getElement(TreePath,ReferenceTree) > + // use DocTrees.getElement(DocTreePath) > public final JCTree qualifierExpression; > public final Name memberName; > public final List paramTypes; > > > JBS: https://bugs.openjdk.java.net/browse/JDK-8071484 > > -- Jon From iris.clark at oracle.com Wed Jul 20 20:10:33 2016 From: iris.clark at oracle.com (Iris Clark) Date: Wed, 20 Jul 2016 13:10:33 -0700 (PDT) Subject: RFR(s) 8161236: Runtime.Version.{compareTo, equals}IgnoreOpt should be renamed Message-ID: Hi. Please review changes in jdk and langtools (module jdk.jshell) to address the following bug: 8161236: Runtime.Version.{compareTo,equals}IgnoreOpt should be renamed https://bugs.openjdk.java.net/browse/JDK-8161236 Webrev: http://cr.openjdk.java.net/~iris/verona/8161236/webrev.0/ We update the method declarations to replace the token "Opt" with "Optional", thus aligning the method names with the associated getter, Runtime.Version.optional(). Specification references to those methods and any uses of the methods were also updated. JPRT runs (testsets hotspot and pit) show no failures related to these changes. A CCC request is in flight. Regards, Iris -------------- next part -------------- An HTML attachment was scrubbed... URL: From robert.field at oracle.com Thu Jul 21 01:15:36 2016 From: robert.field at oracle.com (Robert Field) Date: Wed, 20 Jul 2016 18:15:36 -0700 Subject: RFR(s) 8161236: Runtime.Version.{compareTo, equals}IgnoreOpt should be renamed In-Reply-To: References: Message-ID: <57902238.8090207@oracle.com> Thumbs up on JShell change. -Robert On 07/20/16 13:10, Iris Clark wrote: > Hi. > > > > Please review changes in jdk and langtools (module jdk.jshell) to address the following bug: > > > > 8161236: Runtime.Version.{compareTo,equals}IgnoreOpt should be renamed > > https://bugs.openjdk.java.net/browse/JDK-8161236 > > > > Webrev: > > > > http://cr.openjdk.java.net/~iris/verona/8161236/webrev.0/ > > > > We update the method declarations to replace the token "Opt" with "Optional", thus aligning the method names with the associated getter, Runtime.Version.optional(). Specification references to those methods and any uses of the methods were also updated. > > > > JPRT runs (testsets hotspot and pit) show no failures related to these changes. A CCC request is in flight. > > > > Regards, > > Iris > > From iris.clark at oracle.com Thu Jul 21 04:06:37 2016 From: iris.clark at oracle.com (Iris Clark) Date: Wed, 20 Jul 2016 21:06:37 -0700 (PDT) Subject: RFR(s) 8161236: Runtime.Version.{compareTo, equals}IgnoreOpt should be renamed In-Reply-To: <57902238.8090207@oracle.com> References: <57902238.8090207@oracle.com> Message-ID: <7530576c-f55e-4b17-8d66-febecfe8e056@default> Hi, Robert. Thanks for Reviewing! iris -----Original Message----- From: Robert Field Sent: Wednesday, July 20, 2016 6:16 PM To: Iris Clark; Kumar Srinivasan; Java Core Libs; compiler-dev at openjdk.java.net; kulla-dev at openjdk.java.net Subject: Re: RFR(s) 8161236: Runtime.Version.{compareTo, equals}IgnoreOpt should be renamed Thumbs up on JShell change. -Robert On 07/20/16 13:10, Iris Clark wrote: > Hi. > > > > Please review changes in jdk and langtools (module jdk.jshell) to address the following bug: > > > > 8161236: Runtime.Version.{compareTo,equals}IgnoreOpt should be renamed > > https://bugs.openjdk.java.net/browse/JDK-8161236 > > > > Webrev: > > > > http://cr.openjdk.java.net/~iris/verona/8161236/webrev.0/ > > > > We update the method declarations to replace the token "Opt" with "Optional", thus aligning the method names with the associated getter, Runtime.Version.optional(). Specification references to those methods and any uses of the methods were also updated. > > > > JPRT runs (testsets hotspot and pit) show no failures related to these changes. A CCC request is in flight. > > > > Regards, > > Iris > > From Alan.Bateman at oracle.com Thu Jul 21 11:36:05 2016 From: Alan.Bateman at oracle.com (Alan Bateman) Date: Thu, 21 Jul 2016 12:36:05 +0100 Subject: RFR(s) 8161236: Runtime.Version.{compareTo, equals}IgnoreOpt should be renamed In-Reply-To: References: Message-ID: <563b5669-dc42-599c-ff87-b6eac3851f09@oracle.com> On 20/07/2016 21:10, Iris Clark wrote: > Hi. > > > > Please review changes in jdk and langtools (module jdk.jshell) to address the following bug: > > The rename looks okay to me. -Alan From iris.clark at oracle.com Thu Jul 21 16:15:33 2016 From: iris.clark at oracle.com (Iris Clark) Date: Thu, 21 Jul 2016 09:15:33 -0700 (PDT) Subject: RFR(s) 8161236: Runtime.Version.{compareTo, equals}IgnoreOpt should be renamed In-Reply-To: <563b5669-dc42-599c-ff87-b6eac3851f09@oracle.com> References: <563b5669-dc42-599c-ff87-b6eac3851f09@oracle.com> Message-ID: <3991de58-1791-46c9-ba8a-76100153ca9f@default> Hi, Alan. Thanks! iris -----Original Message----- From: Alan Bateman Sent: Thursday, July 21, 2016 4:36 AM To: Iris Clark; Kumar Srinivasan; Java Core Libs; compiler-dev at openjdk.java.net; kulla-dev at openjdk.java.net Subject: Re: RFR(s) 8161236: Runtime.Version.{compareTo, equals}IgnoreOpt should be renamed On 20/07/2016 21:10, Iris Clark wrote: > Hi. > > > > Please review changes in jdk and langtools (module jdk.jshell) to address the following bug: > > The rename looks okay to me. -Alan From iris.clark at oracle.com Thu Jul 21 21:01:52 2016 From: iris.clark at oracle.com (Iris Clark) Date: Thu, 21 Jul 2016 14:01:52 -0700 (PDT) Subject: RFR(s) 8161236: Runtime.Version.{compareTo, equals}IgnoreOpt should be renamed In-Reply-To: References: Message-ID: Hi, Kumar. Thank you very much for pushing the changesets to resolve this bug! Regards. iris From: Iris Clark Sent: Wednesday, July 20, 2016 1:11 PM To: Kumar Srinivasan; Java Core Libs; compiler-dev at openjdk.java.net; kulla-dev at openjdk.java.net Subject: RFR(s) 8161236: Runtime.Version.{compareTo, equals}IgnoreOpt should be renamed Hi. Please review changes in jdk and langtools (module jdk.jshell) to address the following bug: 8161236: Runtime.Version.{compareTo,equals}IgnoreOpt should be renamed https://bugs.openjdk.java.net/browse/JDK-8161236 Webrev: http://cr.openjdk.java.net/~iris/verona/8161236/webrev.0/ We update the method declarations to replace the token "Opt" with "Optional", thus aligning the method names with the associated getter, Runtime.Version.optional(). Specification references to those methods and any uses of the methods were also updated. JPRT runs (testsets hotspot and pit) show no failures related to these changes. A CCC request is in flight. Regards, Iris -------------- next part -------------- An HTML attachment was scrubbed... URL: From steve.drach at oracle.com Fri Jul 29 18:42:10 2016 From: steve.drach at oracle.com (Steve Drach) Date: Fri, 29 Jul 2016 11:42:10 -0700 Subject: RFR: 8143366 Control characters in constant pool strings are not escaped properly Message-ID: Hi, Please review this simple change to javap so that control characters are displayed. webrev: http://cr.openjdk.java.net/~sdrach/8143366/webrev/index.html issue: https://bugs.openjdk.java.net/browse/JDK-8143366 Thanks, Steve -------------- next part -------------- An HTML attachment was scrubbed... URL: From jonathan.gibbons at oracle.com Fri Jul 29 18:49:00 2016 From: jonathan.gibbons at oracle.com (Jonathan Gibbons) Date: Fri, 29 Jul 2016 11:49:00 -0700 Subject: RFR: 8143366 Control characters in constant pool strings are not escaped properly In-Reply-To: References: Message-ID: <579BA51C.7080504@oracle.com> OK -- jon On 07/29/2016 11:42 AM, Steve Drach wrote: > Hi, > > Please review this simple change to javap so that control characters > are displayed. > > webrev: http://cr.openjdk.java.net/~sdrach/8143366/webrev/index.html > > issue: https://bugs.openjdk.java.net/browse/JDK-8143366 > > Thanks, > Steve > > -------------- next part -------------- An HTML attachment was scrubbed... URL: