RFR: 8247957: remove doclint support for HTML 4 [v5]

Yoshiki Sato ysatowse at openjdk.java.net
Wed Dec 23 08:18:01 UTC 2020

On Wed, 23 Dec 2020 06:42:21 GMT, Yoshiki Sato <ysatowse at openjdk.org> wrote:

>> src/jdk.javadoc/share/classes/jdk/javadoc/internal/doclint/Checker.java line 710:
>>> 708: 
>>> 709: 
>>> 710:     private boolean checkAnchor(String name) {
>> I was going to let it slide for this round of cleanup, but if you're editing this file again (see comment on line 736) it might be worth changing the use of `anchor` to `id`.  `anchor` is a term that was more appropriate in the days before the `id` attribute, when we used `<a name="...">`.  This is an optional suggestion.  It might equally be worth focussing on the must-fix items, and postpone this cleanup for later.
> I understand.  But is it really no problem to be done in part of the cleanup of doclint?  
> Looking at the classes in jdk/javadoc/internal/doclint,  the term `(anchor|Anchor)` looks like only used in Checker.java and resource files.  But a lot of other files, for instance in jdk/javadoc/internal/doclets, use this term to refer to the `id` or `name` attribute.  I would be fine if it is supposed to be done in each cleanup in the future.

If we would apply similar changing to doclint.properties, what you are thinking is like below right?

-dc.anchor.already.defined = anchor already defined: "{0}"
-dc.anchor.value.missing = no value given for anchor
+dc.id.already.defined = attribute "id" already defined: "{0}"
+dc.id.value.missing = no value given for attribute "id"

-dc.invalid.anchor = invalid name for anchor: "{0}"
-dc.invalid.id = invalid name for attribute "id": "{0}"


PR: https://git.openjdk.java.net/jdk/pull/893

More information about the compiler-dev mailing list