RFR: 8280825: Modules that "provide" ToolProvider should document the name that can be used

Alan Bateman alanb at openjdk.java.net
Wed Feb 9 20:35:10 UTC 2022


On Wed, 9 Feb 2022 16:37:00 GMT, Christian Stein <cstein at openjdk.org> wrote:

> A number of modules declare that the "provide" ToolProvider.
> 
> These modules now specify the "name" of the argument used by `ToolProvider.findFirst` to access an instance of the tool provider within the description part of a `@provides` API tag.

src/jdk.jartool/share/classes/module-info.java line 45:

> 43:  *         Pass {@code "jar"} as the name to
> 44:  *         {@link java.util.spi.ToolProvider#findFirst ToolProvider.findFirst}
> 45:  *         in order to obtain an instance of the tool.

I'm not sure about the wording. It might be better to say that it provides a tool named "jar". Invoke findFirst("jar") to create an instance of this tool.

-------------

PR: https://git.openjdk.java.net/jdk/pull/7406


More information about the compiler-dev mailing list