RFR: 8344708: Compiler Implementation of Module Import Declarations [v4]
Alan Bateman
alanb at openjdk.org
Wed Apr 9 17:55:47 UTC 2025
On Wed, 2 Apr 2025 16:59:16 GMT, Jan Lahoda <jlahoda at openjdk.org> wrote:
>> This is a patch to finalize the module imports feature. Please see:
>> https://bugs.openjdk.org/browse/JDK-8344700
>
> Jan Lahoda has updated the pull request incrementally with one additional commit since the last revision:
>
> Reflecting review feedback - avoiding hardcoded constants.
src/java.base/share/classes/jdk/internal/module/ModuleInfo.java line 415:
> 413: if (major >= 54
> 414: && mods.contains(Requires.Modifier.STATIC)) {
> 415: String flagName = "ACC_STATIC_PHASE";
A minor comment on the style here, do you mind combin L413+414 as it will make it easier to read. The change is okay of course.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/23801#discussion_r2035855402
More information about the compiler-dev
mailing list