Adding constant for line.separator and friends
Martin Buchholz
martinrb at google.com
Wed Nov 11 21:48:59 UTC 2009
On Wed, Nov 11, 2009 at 12:46, Stephen Colebourne <scolebourne at joda.org>wrote:
> Martin Buchholz wrote:
>
> On Wed, Nov 11, 2009 at 10:10, Ulf Zibis <Ulf.Zibis at gmx.de <mailto:
>> Ulf.Zibis at gmx.de>> wrote:
>> At least, IMO, fileSeparator() and pathSeparator() would belong to
>> java.io.File or java.nio.file.FileSystem.
>> Those would have been better names,
>> but at this point they are not worth adding.
>>
>
> I don't follow - why are they not worth adding now?
Because java.io.File already provides the functionality users need.
Not in the best way - as fields instead of methods, and
only the first char of the system property. But it's not broken enough
to be worth fixing by providing a slightly better API.
IMO, of course.
> Becuase they should have been in JDK 1.0? Because JDK 7 is about to
> release? Some other reason? How and who is deciding?
>
>
it's a hard problem, and one that Sun/JCP/OpenJDK still needs to address.
I guess right now folks are waiting for the Oracle acquisition.
Martin
> Over the past few weeks I've been tempted to ask for sponsorship of more
> than one idea, change, or useful method (there are lots we could add). But
> the process for what is accepted and what isn't seems very arbitrary. As
> such, I'm just not bothering right now (nor am I working on JSR-310, as the
> same arbitrary rejection could apply to that to).
>
> Stephen
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openjdk.java.net/pipermail/core-libs-dev/attachments/20091111/90d893f6/attachment.html>
More information about the core-libs-dev
mailing list