Review Request CR#7118743 : Alternative Hashing for String with Hash-based Maps

Ulf Zibis Ulf.Zibis at gmx.de
Sat May 26 15:43:51 UTC 2012


Am 24.05.2012 21:34, schrieb Mike Duigou:
> Hello All;
>
> I have updated the webrevs for alternative hashing for String with feedback from Remi, Doug, Ulf and internal reviewers.
>
> Additional feedback is welcome.

Javadoc of String.hash32():
To where refers {@inheritDoc} ?
I think, the javadoc should mention the term 'Murmur hash' and include a web link to the original 
author.

And additionally IMO we should rename hash32() to something like murmurHash32().

But I still think, we should implement a more general approach according my last post.
Correction: the variable customHash should be transient.
Enhancement: again more general for all CharSequence types:
public class MurmurHashMap<V> extends HashMap<CharSequence,V> {...}

Additionally it would be interesting to add a customHash field to plain Java arrays.
This would allow a real hash over the array values, which is not existent now.

-Ulf




More information about the core-libs-dev mailing list