RFR: 8016025 JSR 310: DateTime API Updates IV

Xueming Shen xueming.shen at oracle.com
Fri Jul 12 17:40:00 UTC 2013


Hi

Please help review the update for the JSR310 DateTime API updates IV

http://cr.openjdk.java.net/~sherman/8016025/webrev/

Here is the summary of the updates included in this round of API update:

  - Remove type parameter from ChronoLocalDate as unnecessary to
    simplify API and usage
  - Rename Temporal.periodUntil to until() and in all implementations
  - Added Temporal.isSupported(TemporalUnit) as a complement to
    TemporalAccessor.isSupported(TemporalField)
  - Add support for lenient parsing mechanism with Chronology.resolveDate,
    in subclasses and in TemporalField.
  - Add parsing support in Period for ISO week strings
  - Remove Temporal/getName and ChronoField.getName
    (redundant with toString and ChronoField.name method)
  - ChronoField.DAY_OF_YEAR clarified in case of Calendars and Eras whose
    start day varies from year to year as in Japanese eras.
  - TemporalUnit and ChronoUnit.isDateUnit and isTimeUnit methods renamed
    to isDateBased and isTimeBased.
  - Move static methods in java.time.temporal.Adjusters to Adjuster 
interface
    and remove class Adjusters
  - Move static methods in java.time.temporal.Queries to TemporalQuery and
    remove class Queries
  - Changed OffsetDateTime.INSTANT_COMPARATOR froma field to a method
  - WeekFields updated to specific the lenient resolution modes
  - DateTimeFormatterBuilder cleanup of parsing of ZoneIds to match
    ZoneId.of syntax.
  - HijrahChronology updated the syntax for the BCP 47 based locale string
    to use "-u-ca-islamic-umalqura"
  - IsoChronology - narrowed the return type of getEra to IsoEra
  - JapaneseChronology/Date/Era
  - Japanese calendar starts with Meiji 6 to avoid ill defined
    early years of Meiji calendar.
  - Remove editorial error "(1865-04-07 - 1868-09-07)" as the Meiji range
    in the JapaneseChronology API doc.
  - Remove JapaneseEra.SEIREKI as ill defined and unnecessary;
   - Update the signature of ChronoLocalDate.atTime

The webrev also includes the proposed change for
JDK-8020418: Cleanup of -Xlint warnings in java.time

Thanks,
-Sherman



More information about the core-libs-dev mailing list