RFR 8012647: Add Arrays.parallelPrefix (prefix sum, scan, cumulative sum)
Chris Hegarty
chris.hegarty at oracle.com
Thu Jun 13 09:30:52 UTC 2013
On 06/12/2013 05:07 PM, Alan Bateman wrote:
> On 12/06/2013 15:50, Chris Hegarty wrote:
>> ...
> Is the name final? Just curious if other names such as parallelScan have
> been considered (and discarded).
I think we should be open to discussing the name, but I will have to
defer to Doug as to whether other names were considered/discarded.
It seems the convention we are adopting for naming these new methods,
whose implementation is parallelized, is to prefix the name with
'parallel' ( parallelSort, parallelSetAll ). Sounds fine. Otherwise I
would have preferred something like prefixScan(..).
Options so far:
parallelPrefix(..) // what we have today
parallelScan(..)
parallelPrefixScan(..) // too long winded??
> "Cumulates in parallel each element ...", I guess I would put a comma
> before and after "in parallel".
Yes, I will add this.
> Otherwise the API looks good to me.
Thanks Alan,
-Chris.
>
> -Alan.
>
>
>
More information about the core-libs-dev
mailing list