RFR 8065998: Avoid use of _ as a one-character identifier
Alan Bateman
Alan.Bateman at oracle.com
Mon Dec 1 13:20:20 UTC 2014
On 01/12/2014 12:10, Jan Lahoda wrote:
> Hi,
>
> In a preparation for JDK-8061549, I'd like to rename all uses of '_'
> as a one-character identifier in the jaxp and jdk repositories. All
> the uses I was able to find are in tests, and the identifier is used
> as a name of a catch parameter. The proposed new name is "ignore", but
> if a different name would be more appropriate, I'll be happy to use it.
>
> Webrev for the jaxp repository:
> http://cr.openjdk.java.net/~jlahoda/8065998/webrev.00/jaxp/
>
> Webrev for the jdk repository:
> http://cr.openjdk.java.net/~jlahoda/8065998/webrev.00/jdk/
In JAXP test Bug4969089 then "ignore" looks a bit odd given that it's in
a method declaration.
In TypeCheckMicroBenchmark then "ignore" is might be a misleading too
given that the ArrayStoreException causes a CCE to be thrown.
-Alan
More information about the core-libs-dev
mailing list