RFR:JDK-8032510 : Add java.time.Duration.dividedBy(Duration)
Roger Riggs
Roger.Riggs at Oracle.com
Fri Dec 11 15:54:06 UTC 2015
Hi Nadeesh,
The API looks fine.
I think the tests would be more readable if the Durations being tested
were created in the data provider.
Without a comment, it just looks like a lot of numbers.
The test methods arguments would then be (Duration dividend, Duration
divisor, long expected).
+ @DataProvider(name="dividedByDur_provider")
+ Object[][] provider_dividedByDur() {
+ return new Object[][] {
+ {new Duration.ofSeconds(0, 0), new Duration.ofSeconds(1, 0), 0},
etc.
Thanks, Roger
On 12/11/2015 7:14 AM, Stephen Colebourne wrote:
> Fine by me.
>
> Stephen
>
> On 11 December 2015 at 11:53, nadeesh tv <nadeesh.tv at oracle.com> wrote:
>> Hi all,
>> Please see the updated webrev
>> http://cr.openjdk.java.net/~ntv/8032510/webrev.03/
>> Regards,
>> Nadeesh TV
>>
>>
>> On 12/11/2015 4:45 PM, Stephen Colebourne wrote:
>>> Missing blank line after the new method.
>>> Typo: "diviosr"
>>> Replace:
>>> Objects.requireNonNull(divisor, "divisor is null");
>>> with
>>> Objects.requireNonNull(divisor, "divisor");
>>> to match existing JSR-310 code.
>>>
>>> Test case looks fine.
>>>
>>> thanks
>>> Stephen
>>>
>>>
>>> On 11 December 2015 at 11:07, nadeesh tv <nadeesh.tv at oracle.com> wrote:
>>>> Hi all,
>>>> Please review a fix for
>>>>
>>>> Bug Id - https://bugs.openjdk.java.net/browse/JDK-8032510
>>>>
>>>> Enhancement - Add java.time.Duration.dividedBy(Duration)
>>>>
>>>> webrev - http://cr.openjdk.java.net/~ntv/8032510/webrev.02/
>>>>
>>>> --
>>>> Thanks and Regards,
>>>> Nadeesh TV
>>>>
>> --
>> Thanks and Regards,
>> Nadeesh TV
>>
More information about the core-libs-dev
mailing list