RFR 8064924: Update java.net.URL to work with modules

Alan Bateman Alan.Bateman at oracle.com
Wed Feb 4 14:44:17 UTC 2015


On 04/02/2015 14:29, Peter Levart wrote:
> :
>
> I agree that this is the most appropriate way with which you can force 
> some provider's class code (the constructor) in the call stack so that 
> you get correct AccessControlContext to check against. But the name 
> starts to sound like German words. :-)
>
> Wouldn't URLStreamHandlerProvider be enough? Since it's a provider for 
> URLStreamHandlers and not URLStreamHandlerFactories.
If URLStreamHandlerFactory were an abstract class rather than an 
interface then this would have been easy. I agree the naming is awkward 
as this abstract class is a URLStreamHandlerFactory rather than a 
provider of URLStreamHandlerFactory objects. Renaming it to 
URLStreamHandlerProvider seems a good idea.

-Alan



More information about the core-libs-dev mailing list