RFR 8080418 Add Optional.or()

Stefan Zobel spliterator at gmail.com
Mon Sep 28 18:00:38 UTC 2015


In the OptionalDouble/Int/Long Javadoc of method "empty()"


* {@code Optional.empty()}. There is no guarantee that it is a singleton.


should be


* {@code OptionalDouble.empty()}.  There is no guarantee that it is a
singleton.

and so on.


Stefan


2015-09-28 11:24 GMT+02:00 Paul Sandoz <paul.sandoz at oracle.com>:

>
> > On 26 Sep 2015, at 21:36, Chris Hegarty <chris.hegarty at oracle.com>
> wrote:
> >
> >
> >> On 25 Sep 2015, at 11:58, Paul Sandoz <paul.sandoz at oracle.com> wrote:
> >>
> >> Hi,
> >>
> >> Please review this change to add a method Optional.or that allows one
> to better compose optionals:
> >>
> >>
> http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8080418-optional-or/webrev/
> >>
> >> I also took the opportunity to clear up the JavaDoc, it was a little
> inconsistent and i personally found it harder to read in source code.
> >
> > The new method and code cleanup look good.
> >
> > Not related to your changes, but I noticed when reviewing the clean up,
> typo “OptionAL.empty()"
> >
> >  L80 * {@code Option.empty()}. There is no guarantee that it is a
> singleton.
> >
>
> Thanks, updated,
> Paul.
>



More information about the core-libs-dev mailing list