RFR(S): 8154751: MethodHandles.countedLoop does not accept empty bodies

Michael Haupt michael.haupt at oracle.com
Fri Apr 22 12:40:26 UTC 2016


Hi Claes,

thank you. I've applied the refactoring - see http://cr.openjdk.java.net/~mhaupt/8154751/webrev.01/ for an update.

Best,

Michael

> Am 22.04.2016 um 12:09 schrieb Claes Redestad <claes.redestad at oracle.com>:
> 
> Hi Michael,
> 
> voidReturn ? zero(void.class) : identity(init.type().returnType()) is used twice, breaking it out to variable would improve readability, possibly performance. Same goes for the subexpression init.type().returnType() which is used three times currently.
> 
> Otherwise it looks fine to me.
> 
> Thanks!
> 
> /Claes
> 
> On 2016-04-20 15:13, Michael Haupt wrote:
>> Dear all,
>> 
>> please review this change.
>> Bug: https://bugs.openjdk.java.net/browse/JDK-8154751
>> Webrev: http://cr.openjdk.java.net/~mhaupt/8154751/webrev.00/
>> 
>> Thanks,
>> 
>> Michael
>> 
> 

-- 

 <http://www.oracle.com/>
Dr. Michael Haupt | Principal Member of Technical Staff
Phone: +49 331 200 7277 | Fax: +49 331 200 7561
Oracle Java Platform Group | LangTools Team | Nashorn
Oracle Deutschland B.V. & Co. KG | Schiffbauergasse 14 | 14467 Potsdam, Germany

ORACLE Deutschland B.V. & Co. KG | Hauptverwaltung: Riesstraße 25, D-80992 München
Registergericht: Amtsgericht München, HRA 95603

Komplementärin: ORACLE Deutschland Verwaltung B.V. | Hertogswetering 163/167, 3543 AS Utrecht, Niederlande
Handelsregister der Handelskammer Midden-Nederland, Nr. 30143697
Geschäftsführer: Alexander van der Ven, Jan Schultheiss, Val Maher
 <http://www.oracle.com/commitment>	Oracle is committed to developing practices and products that help protect the environment




More information about the core-libs-dev mailing list