RFR: 6543126: Level.known can leak memory

Mandy Chung mandy.chung at oracle.com
Thu Aug 11 19:12:14 UTC 2016


> On Aug 11, 2016, at 2:29 AM, Daniel Fuchs <daniel.fuchs at oracle.com> wrote:
> 
> On 10/08/16 17:21, Mandy Chung wrote:
>>> On Jul 29, 2016, at 4:54 AM, Daniel Fuchs <daniel.fuchs at oracle.com> wrote:
>>> >
>>> > http://cr.openjdk.java.net/~dfuchs/webrev_6543126/webrev.01/
>> This looks pretty good.
>> 
>> Since KnownLevel is now a Reference, I suggest to change KnownLevel::findByName, findByValue and findByLocalizedLevelName to return Optional<Level> instead such that the parse method implementaiton could be simplified.
> 
> We need to return KnownLevel because sometimes we need the
> level object and sometimes the mirror.

So either findByName(String name, boolean mirror) or two methods: findLevelByName and findMirroredLevelByName??

Or seriously consider to remove KnownLevel class by introducing a new Level subclass with final Level.getName, Level.getLocalizedName, Level.getResourceBundleName methods??

Mandy


More information about the core-libs-dev mailing list