RFR(M): 8150832: split T8139885 into several tests by functionality

Claes Redestad claes.redestad at oracle.com
Wed Mar 2 12:59:50 UTC 2016


this looks good to me.

Maybe rename LoopTest to LoopCombinatorTest to add a bit of specificity?


On 2016-03-02 13:46, Michael Haupt wrote:
> Dear all,
> please review this change.
> RFE: https://bugs.openjdk.java.net/browse/JDK-8150832
> Webrev: http://cr.openjdk.java.net/~mhaupt/8150832/webrev.00
> This is a refactoring; the monolithic test for JEP 274 was split into several tests along functionality covered. Also, data providers and other declarative annotations were introduced where it made sense.
> Thanks,
> Michael

More information about the core-libs-dev mailing list