RFR: 8163798: Create a JarFile versionedStream method
Mandy Chung
mandy.chung at oracle.com
Mon Sep 12 23:26:20 UTC 2016
> On Sep 12, 2016, at 2:17 PM, Steve Drach <steve.drach at oracle.com> wrote:
>
> Here’s a new webrev addressing Paul’s additional concerns
>
> http://cr.openjdk.java.net/~sdrach/8163798/webrev.04/ <http://cr.openjdk.java.net/~sdrach/8163798/webrev.04/>
This version looks good.
Can you add the javadoc to describe what the stream method returns (a union of the base entries + all versioned entries <= JarFile::getVersion.
Nit: you may want to call jf.getVersion().major() once rather than the number of entries.
Now that you have jdk.internal.util.jar internal API for MRJAR. It may be useful to add a static getRealName(JarFile jar, JarEntry entry) method for convenience such that jdeps and jlink can use this MRJAR-specific internal API and no need to use the shared secret. Maybe rename VersionedStream to VersionedJarFileHelper?
TestVersionedStream::close
You may want to use jdk.testlibrary.FileUtils and deleteFileTreeWithRetry may be what you want.
Mandy
More information about the core-libs-dev
mailing list