JDK 9 RFR(s): 8167981: Optional: add notes explaining intended use

Stuart Marks stuart.marks at oracle.com
Thu Apr 20 20:21:22 UTC 2017



On 4/20/17 10:03 AM, Martin Buchholz wrote:
> This looks good.
>
> I don't think there's any need anymore to have fully qualified class names in
> @links, so just:
>
> {@link #orElseGet(Supplier) orElseGet}
>
> (but there's a global cleanup there)

Thanks for reviewing.

Yes, "java.util.function.Supplier" is unnecessary. "Supplier" is sufficient in 
this context, since the file imports java.util.function.Supplier, and javadoc 
respects imports. I've fixed this occurrence and one other similar unnecessarily 
fully-qualified name in the class doc. (Along with corresponding changes in 
Optional{Double,Int,Long}.)

> I would write
> "result".
> instead of
> "result."
>
> (but the latter has never made sense to me even as a child)

Yeah, this is a long-standing usage dispute over typography, probably dating 
back to before there were programming languages. I don't think we're going to 
resolve it here. :-)

s'marks


More information about the core-libs-dev mailing list