RFR 4358774: Add null InputStream and OutputStream
Brian Burkhalter
brian.burkhalter at oracle.com
Fri Dec 8 18:38:29 UTC 2017
Patrick’s comment made us think again about the naming here as “nullStream()” would not fit for eventual equivalent methods on Reader and Writer. It might be better to go with something like
InputStream InputStream.nullSource();
OutputStream.nullSink();
and later
Reader.nullSource();
Writer.nullSink();
Another alternative would be simply to reflect the class names in the methods:
InputStream InputStream.nullInputStream();
OutputStream.nullOutputStream();
and later
Reader.nullReader();
Writer.nullWriter();
Comments?
Thanks,
Brian
On Dec 6, 2017, at 12:36 PM, Patrick Reinhart <patrick at reini.net> wrote:
> Is there also a issue for the same kind of methods for Reader and Writer?
More information about the core-libs-dev
mailing list