RFR 4358774: Add null InputStream and OutputStream

Brian Burkhalter brian.burkhalter at oracle.com
Mon Dec 11 20:52:07 UTC 2017


On Dec 8, 2017, at 3:12 PM, Brian Burkhalter <brian.burkhalter at oracle.com> wrote:

> All previous suggested changes have been made in
> 
> http://cr.openjdk.java.net/~bpb/4358774/webrev.03/
> 
> except for the possible change of name for the IS and OS nullStream() methods which awaits consensus.

As long as we’re still at it, given java.util.stream.Stream then

InputStream.nullInput()
OutputStream.nullOutput()
Reader.nullReader()
Writer.nullWriter()

might not be a bad alternative.

Thanks,

Brian


More information about the core-libs-dev mailing list