RFR: [XXS] 8214744: Unnecessary <p> tags in java.util.zip.Deflater
Martin Buchholz
martinrb at google.com
Tue Dec 4 00:20:42 UTC 2018
LGTM
On Mon, Dec 3, 2018 at 4:07 PM Jonathan Gibbons <jonathan.gibbons at oracle.com>
wrote:
> Please review this small patch, given below, to remove unnecessary <p>
> reported by `tidy` as the last remaining HTML issues in the
> documentation for java.base
>
> build/linux-x86_64-server-release/images/docs/api/java.base/java/util/zip/Deflater.html:827:2:
> Warning: trimming empty <p>
> build/linux-x86_64-server-release/images/docs/api/java.base/java/util/zip/Deflater.html:850:2:
> Warning: trimming empty <p>
>
> JBS: https://bugs.openjdk.java.net/browse/JDK-8214744
>
> -- Jon
>
>
> $ hg diff -R open open/src
> diff -r 2eb8ae0f3454
> src/java.base/share/classes/java/util/zip/Deflater.java
> --- a/src/java.base/share/classes/java/util/zip/Deflater.java Mon Dec 03
> 18:48:01 2018 +0100
> +++ b/src/java.base/share/classes/java/util/zip/Deflater.java Mon Dec 03
> 15:57:17 2018 -0800
> @@ -224,7 +224,6 @@
> * One of the {@code setInput()} methods should be called whenever
> * {@code needsInput()} returns true indicating that more input data
> * is required.
> - * <p>
> * @param input the input data bytes
> * @param off the start offset of the data
> * @param len the length of the data
> @@ -248,7 +247,6 @@
> * One of the {@code setInput()} methods should be called whenever
> * {@code needsInput()} returns true indicating that more input data
> * is required.
> - * <p>
> * @param input the input data bytes
> * @see Deflater#needsInput
> */
>
>
More information about the core-libs-dev
mailing list