RFR: Rename EFS in java.util.zip internals to something meaningful

Martin Buchholz martinrb at google.com
Thu May 17 13:08:52 UTC 2018


Yup, I missed FLAG_EFS.

diff --git a/src/jdk.zipfs/share/classes/jdk/nio/zipfs/ZipConstants.java
b/src/jdk.zipfs/share/classes/jdk/nio/zipfs/ZipConstants.java
--- a/src/jdk.zipfs/share/classes/jdk/nio/zipfs/ZipConstants.java
+++ b/src/jdk.zipfs/share/classes/jdk/nio/zipfs/ZipConstants.java
@@ -47,7 +47,7 @@ class ZipConstants {
      */
     static final int FLAG_ENCRYPTED  = 0x01;
     static final int FLAG_DATADESCR  = 0x08;    // crc, size and csize in
dd
-    static final int FLAG_EFS        = 0x800;   // If this bit is set the
filename and
+    static final int FLAG_USE_UTF8   = 0x800;   // If this bit is set the
filename and
                                                 // comment fields for this
file must be
                                                 // encoded using UTF-8.
     /*
diff --git a/src/jdk.zipfs/share/classes/jdk/nio/zipfs/ZipFileSystem.java
b/src/jdk.zipfs/share/classes/jdk/nio/zipfs/ZipFileSystem.java
--- a/src/jdk.zipfs/share/classes/jdk/nio/zipfs/ZipFileSystem.java
+++ b/src/jdk.zipfs/share/classes/jdk/nio/zipfs/ZipFileSystem.java
@@ -1374,7 +1374,7 @@ class ZipFileSystem extends FileSystem {
         // store size, compressed size, and crc-32 in LOC header
         e.flag = 0;
         if (zc.isUTF8())
-            e.flag |= FLAG_EFS;
+            e.flag |= FLAG_USE_UTF8;
         OutputStream os;
         if (useTempFile) {
             e.file = getTempPathForEntry(null);


On Wed, May 16, 2018 at 11:13 PM, Xueming Shen <xueming.shen at oracle.com>
wrote:

> On 5/16/18, 6:28 PM, Martin Buchholz wrote:
>
>> Hi Xueming, I'd like you to do a code review
>>
>> 8203328: Rename EFS in java.util.zip internals to something meaningful
>> http://cr.openjdk.java.net/~martin/webrevs/jdk/zip-EFS/ <
>> http://cr.openjdk.java.net/%7Emartin/webrevs/jdk/zip-EFS/>
>> https://bugs.openjdk.java.net/browse/JDK-8203328
>>
>> looks good. thanks for fixing the misleading name i put in 10 years ago
> :-)
> btw, you might as well want to fix the same constant in  zipfs at
> src/jdk.zipfs/share/classes/jdk/nio/zipfs/ZipConstands.java/FLAG_EFS
>


More information about the core-libs-dev mailing list