RFR: 8174222: LambdaMetafactory: validate inputs and improve documentation

Brian Goetz brian.goetz at oracle.com
Thu Mar 21 14:58:37 UTC 2019

+1 from me.

> http://cr.openjdk.java.net/~dlsmith/8174222/webrev.00/


I see you renamed most of the fields and params.  Most of these are 
improvements, but it may be worth being more explicit in ambiguous 
cases.  For example, there are two method names, so perhaps instead of 
`methodName` it should be `interfaceMethodName` to make it clear this is 
the SAM method and not the implementation method.

I presume the SecurityException is something that was always thrown, and 
we are just documenting it now.  Should that be wrapped in a LCE instead?

(Similar for ICLMF)


Accidentally lost the {@code ...} surrounding MethodHandle in class 

More information about the core-libs-dev mailing list