JDK 13 RFR of JDK-8223178: Improve FileSystems.newFileSystem example with map factory methods
Alan Bateman
Alan.Bateman at oracle.com
Wed May 1 06:16:49 UTC 2019
On 01/05/2019 02:59, Joe Darcy wrote:
> :
>
> --- a/src/java.base/share/classes/java/nio/file/FileSystems.java Tue
> Apr 30 16:11:42 2019 -0700
> +++ b/src/java.base/share/classes/java/nio/file/FileSystems.java Tue
> Apr 30 18:52:11 2019 -0700
> @@ -252,10 +252,9 @@
> * Suppose there is a provider identified by the scheme {@code
> "memory"}
> * installed:
> * <pre>
> - * Map<String,String> env = new HashMap<>();
> - * env.put("capacity", "16G");
> - * env.put("blockSize", "4k");
> - * FileSystem fs =
> FileSystems.newFileSystem(URI.create("memory:///?name=logfs"), env);
> + * FileSystem fs =
> FileSystems.newFileSystem(URI.create("memory:///?name=logfs"),
> + * Map.of("capacity", "16G",
> + * "blockSize", "4k"));
Changing it to use an unmodifable map is good. One nit the really long
line in the source will be annoying with future side-by-side diffs. It
wouldn't take much from the readability to keep env.
-Alan
More information about the core-libs-dev
mailing list