RFR: 8242596: Improve JarFile.getEntry performance for multi-release jar
Lance Andersen
lance.andersen at oracle.com
Thu Apr 16 14:33:26 UTC 2020
Hi Claes,
Hi Claes,
I think this looks good. I few minor comments/suggestions:
JavaUtilZipFileAccess.java:Please update the copyright
JarFile.java: In getVersionEntry(), can we place break the if statements onto two lines to make it a bit easier to read?
ZipFile.java: Perhaps add a comment around 690 as to why this code was added for future maintainers
Best
Lance
> On Apr 16, 2020, at 8:48 AM, Claes Redestad <claes.redestad at oracle.com> wrote:
>
> Hi,
>
> please review this patch to improve JarFile.getEntry performance
> on multi-release jar files, mainly contributed by Eirik Bjørsnøs.
>
> The main idea is to piggy-back on the scanning of meta-inf entries
> we already do during initCEN to scan what versions exists in the
> jar file. This then reduces the number of lookups we'll have to do
> in typical scenarios.
>
> Webrev: http://cr.openjdk.java.net/~redestad/8242596/open.00/
> Bug: https://bugs.openjdk.java.net/browse/JDK-8242596
>
> Testing: tier1-2
>
> Thanks!
>
> /Claes
<http://oracle.com/us/design/oracle-email-sig-198324.gif>
<http://oracle.com/us/design/oracle-email-sig-198324.gif> <http://oracle.com/us/design/oracle-email-sig-198324.gif>
<http://oracle.com/us/design/oracle-email-sig-198324.gif>Lance Andersen| Principal Member of Technical Staff | +1.781.442.2037
Oracle Java Engineering
1 Network Drive
Burlington, MA 01803
Lance.Andersen at oracle.com <mailto:Lance.Andersen at oracle.com>
More information about the core-libs-dev
mailing list