RFR: 5023614: UUID needs methods to get most/leastSigBits and write to DataOutput
Richard Fussenegger
github.com+1059453+fleshgrinder at openjdk.java.net
Tue Jan 12 07:29:00 UTC 2021
On Mon, 14 Dec 2020 20:18:01 GMT, Roger Riggs <rriggs at openjdk.org> wrote:
>> Made byte constructor public and changed the length assertion to an `IllegalArgumentException`, added a `getBytes` method that allows users to retrieve the raw bytes of the UUID, and created a new private constructor with an optimized construction for byte arrays that can set the version as desired and the variant to RFC 4122. Also changed the existing static factory methods to use the new constructor and removed the duplicate code from them where the variant and version is being set.
>>
>> Report [5023614](https://bugs.java.com/bugdatabase/view_bug.do?bug_id=5023614) asks for more than what I provided and with different names. However, I believe that there is no value in providing methods to deal with `DataInput` and `DataOutput` because they would only encapsulate single method calls that the caller can directly write as well (e.g. `output.write(uuid.getBytes())` vs `uuid.write(output)`). Hence, I consider this change to satisfy the feature request.
>
> Requested feedback on the API addition/modifications:
> https://mail.openjdk.java.net/pipermail/core-libs-dev/2020-December/072530.html
Active
-------------
PR: https://git.openjdk.java.net/jdk/pull/1465
More information about the core-libs-dev
mailing list